85 lines
2.1 KiB
Nix
85 lines
2.1 KiB
Nix
# Do not modify this file! It was generated by 'nixos-generate-config'
|
|
# and may be overwritten by future invocations. Please make changes
|
|
# to /etc/nixos/configuration.nix instead.
|
|
{ config, lib, pkgs, modulesPath, ... }:
|
|
|
|
{
|
|
imports =
|
|
[
|
|
(modulesPath + "/installer/scan/not-detected.nix")
|
|
];
|
|
|
|
# Hardware Configuration
|
|
hardware = {
|
|
enableRedistributableFirmware = lib.mkForce true;
|
|
firmware = lib.mkForce [ pkgs.linux-firmware ];
|
|
|
|
graphics = {
|
|
enable = true;
|
|
enable32Bit = true;
|
|
extraPackages = with pkgs; [
|
|
libva
|
|
vaapiVdpau
|
|
v4l-utils
|
|
];
|
|
};
|
|
|
|
cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
|
|
};
|
|
|
|
# Boot Configuration
|
|
boot = {
|
|
loader = {
|
|
systemd-boot.enable = true;
|
|
efi.canTouchEfiVariables = true;
|
|
};
|
|
|
|
initrd = {
|
|
availableKernelModules = [
|
|
"nvme"
|
|
"xhci_pci"
|
|
"usbhid"
|
|
"usb_storage"
|
|
"sd_mod"
|
|
"sdhci_pci"
|
|
];
|
|
kernelModules = [ "amdgpu" "kvm-amd" ];
|
|
};
|
|
|
|
kernelModules = [ "amdgpu" "v4l2loopback" "snd-aloop" "kvm-amd" ];
|
|
extraModulePackages = [ pkgs.linuxPackages_latest.v4l2loopback ];
|
|
};
|
|
|
|
# Filesystem Configuration
|
|
fileSystems."/" = {
|
|
device = "/dev/disk/by-uuid/f3cc4aae-428e-435d-b9f7-333f7dad06b2";
|
|
fsType = "ext4";
|
|
};
|
|
|
|
fileSystems."/boot" = {
|
|
device = "/dev/disk/by-uuid/580E-5E90";
|
|
fsType = "vfat";
|
|
options = [ "fmask=0077" "dmask=0077" ];
|
|
};
|
|
|
|
# Optional SteamOS games mount (commented out)
|
|
# fileSystems."/mnt/steamos" = {
|
|
# device = "/dev/disk/by-uuid/5261b393-9b3e-4334-9ddf-4a1eb9865905";
|
|
# fsType = "ext4";
|
|
# };
|
|
|
|
# Swap Configuration
|
|
swapDevices = [ ]; #TODO: consider releasing the zram swapfile and utilizing the one already on steamos
|
|
|
|
# Network Configuration
|
|
networking.useDHCP = lib.mkDefault true;
|
|
# networking.interfaces.enp4s0f3u1u4u4.useDHCP = lib.mkDefault true;
|
|
# networking.interfaces.wlo1.useDHCP = lib.mkDefault true;
|
|
|
|
# Platform Configuration
|
|
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
|
|
|
|
# System State Version
|
|
system.stateVersion = "24.05";
|
|
}
|