19 lines
378 B
Nix
19 lines
378 B
Nix
{ config, pkgs, ... }:
|
|
{
|
|
# Enable CUPS printing service
|
|
services.printing.enable = true;
|
|
|
|
# Enable network printer discovery
|
|
services.avahi = {
|
|
enable = true;
|
|
nssmdns4 = true;
|
|
openFirewall = true;
|
|
};
|
|
|
|
# Install HP printer drivers
|
|
services.printing.drivers = [
|
|
pkgs.hplip
|
|
pkgs.hplipWithPlugin # For printers requiring proprietary plugins
|
|
];
|
|
}
|