blockchain-risk-analyzer/shell.nix
jeirmeister 391a2fa35d Initial commit: Blockchain fraud detection analyzer
Initial implementation of a tool to analyze Ethereum smart contracts for fraudulent patterns.
Currently supports:
- Contract deployment analysis
- Early actor identification
- Exchange interaction tracking
- Wash trading detection
- Suspicious pattern recognition

Known issues:
- Directory structure needs cleanup
- Some indentation errors to fix
- Missing proper error handling
- Needs better report formatting
2024-11-10 16:10:27 -08:00

24 lines
467 B
Nix

# shell.nix
{ pkgs ? import <nixpkgs> {} }:
pkgs.mkShell {
buildInputs = with pkgs; [
python312
python312Packages.pip
python312Packages.virtualenv
];
shellHook = ''
# Create and activate virtual environment
python -m venv .venv
source .venv/bin/activate
# Install requirements if they exist
if [ -f requirements.txt ]; then
pip install -r requirements.txt
fi
echo "Python virtual environment activated"
'';
}