18 lines
324 B
Nix
18 lines
324 B
Nix
{ config, pkgs, ... }:
|
|
{
|
|
users.users.nixos = {
|
|
isNormalUser = true;
|
|
extraGroups = [ "wheel" ];
|
|
};
|
|
|
|
security.sudo.wheelNeedsPassword = true;
|
|
|
|
services.openssh = {
|
|
enable = true;
|
|
settings = {
|
|
AllowUsers = ["nixos"];
|
|
PasswordAuthentication = true;
|
|
PermitRootLogin = "no";
|
|
};
|
|
};
|
|
} |